Post

May 06
Version History for MS CRM 2015

   

     

Microsoft Dynamics CRM 2015

Name

Date

Build

KB-Article   

RTM

Sept 2014

7.0.0.3543

   

Update 0.1

14. April 2015

7.0.1.129

https://support.microsoft.com/kb/3010990

"Carina"
only for CRM Online

4. May 2015

7.1.0

   

Apr 02
Build a simple report for CRM Online (Version 2015)

 

I searched on the web for a simple explanation what I need to do to create a simple report for CRM Online. Surprisingly I found no explanation except one from Donna Edwards from Dec. 2012 and so I decided to write a new one with the latest toolset needed for MS CRM Online 2015.

First step is to install all necessary applications on your desktop.

System Requirements to design reports:

After installing the applications mentioned above, go to VS 2012 and create a new Project.

The Welcome to Report Wizard window opens. Click Next and fill in your credentials.

Go to Credentials.. and fill in "use a specific user name and password".

Click on OK and Next on the "Select Data Source Window".
Now the "Design the Query" screen will open.

At this point build and insert a FetchXML. There are multiple ways to get to a FetchXMl. I prefer the following two:

  1. Build the query with Advanced View in CRM Online and when finished click on "Download Fetch XML" or
  2. Use the FetchXML Builder from the www.xrmtoolbox.com

For this example I used a very simple one:

Click on Next and select the style "Tabular" or "Matrix". On the next screens specify the design for the report and click on Finish.
The result is now the following:

Now we have generated our first Report for MS CRM Online and we can upload it into CRM.

To upload this report open CRM and find the "Report" Section. Normally it is located under Sales->Reports.
There click on NEW:

Fill in all the necessary fields like the Category, Related Record Types,..
The most important step is to define the "File Location". This should point to the rdl file generated before.

After filling in all the fields click on Save and Close. Now mark the Report and click on Run Report

WHOOHOO—Here is our first published report:

Hope this helps getting started with building reports for CRM Online.

Feb 09
Does not have update permission for the openrevenue attribute

I had to fight today with a strange error message when someone changes the currency of an account.

Unhandled Exception: System.ServiceModel.FaultException`1...

Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=7.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: User with ID aab02be9-21b6-e211-b855-00155dc80c25 does not have Update permissions for the openrevenue attribute in the account entity. The accountid of the record is 859f5947-2eb0-e411-80c9-00155dc8d406Detail:

<OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">

  <ErrorCode>-2147158777</ErrorCode>

  <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />

  <Message>User with ID aab02be9-21b6-e211-b855-00155dc80c25 does not have Update permissions for the openrevenue attribute in the account entity. The accountid of the record is 859f5947-2eb0-e411-80c9-00155dc8d406</Message>

  <Timestamp>2015-02-09T08:18:41.3783228Z</Timestamp>

  <InnerFault i:nil="true" />

  <TraceText i:nil="true" />

</OrganizationServiceFault>

   

After some research we found out that since the upgrade to MS CRM 2015 only the System Administrator was able to change the currency. Because we haven't changed anything else we first looked into the security roles.

We hoped to find a new privilege which were added when we upgraded to CRM 2015 and we have to add to the user security role, but I haven't found an appropriate privilege.
Because I never activated field security we never thought that it could be the field security, but because we haven't found a privilege we took a deeper look into field security and found out that for the "openrevenue" the field security was turned on by default after the upgrade.

We tried to add "allow update" for this field, but for some reason we were not able to change it.

Therefore we found as only workaround the possibility to turn off the field security for the "openrevenue" field.

If someone can tell me why I am not able to give the "allow update" field security right it would be very helpful

  

Feb 02
Workaround for “Process_Custom_Attribute_URL” error

As described in my previous blog I found a bug in the actual CRM Online version. This results in the behavior that it is not possible anymore to use the Record URL(Dynamic) field in a wait condition.

This is a big issue for us because we use this field a lot when generating documents with our Add-On DocumentsCorePack in workflows.

To come around this problem we wrote a very simple Solution which contains a single CustomWorkflowActivity.The solution is attached to this blog article and I will describe now how to use it.

  1. Download the DynamicRecordUrlWorkaround_2015_1_managed.zip solution and import it.
  2. Open the process in which you want to use the RecordURL(Dynamic) field
  3. You have now the possibility to add the DynamicRecordURL Workaround->DynamicREcordURL.GetDynamicRecordURL workflow step.
  4. Click on the Set Properties after you inserted the step and fill in the RecordURL(Dynamic) you want to use in the wait condition. Please be careful that you insert the custom workflow step outside of the condition.
  5. In the step where you want to use the RecordUrl(Dynamic) you now take the return value of the DynamicRecordURL Workaround custom workflow activity we inserted .
  6. That's it.

 

This works fine for me. Hopefully also in your case.

 

Jan 30
Process_Custom_Attribute_URL error in processes

I have a strange problem in multiple projects with CRM 2015 Online.

Workflows which worked in CRM 2013 stopped working after the upgrade and also with new workflows I get the following error:

Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=7.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Unable to find metadata information for attribute !Process_Custom_Attribute_URL_Detail:
<OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
<ErrorCode>-2147220970</ErrorCode>
<ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/…/System.Collections.Generic" />
<Message>Unable to find metadata information for attribute !Process_Custom_Attribute_URL_</Message>
<Timestamp>2015-01-26T04:50:37.1685174Z</Timestamp>
<InnerFault i:nil="true" />
<TraceText i:nil="true" />
</OrganizationServiceFault>

I have now done some further testing and found out that this error can be reproduced in a clean new demo environment of CRM 2015 Online.

These are the steps to reproduce:

  1. Create a simple workflow. In my case I created a workflow for account.

     

  2. As you see I added a simple wait condition. The field and value of the condition does not really matter.
  3. Then I add a create step. Again it does not matter which entity I want to create.
  4. When I now click on the "Set Properties" and insert in one of the fields the Record URL(Dynamic)
  5. Now I click on "Save and Close" and get the errormessage from above

 

Because I tested this now also in a clean new Test-Org I think it has to be a general bug in the actual CRM Online version.

I already opened a ticket at Microsoft. If anyone has an Idea how to resolve this I would really appreciate it.

 

Thx

Jan 30
Get Guid of an Entity Record in CRM 2013/2015

 

I often need when I am working with CRM the ID of a record and came across the blog article from Tim Dutcher to add a favorite to IE to get quickly the GUID.

http://mscrmrocks.blogspot.co.at/2012/08/showcopy-id-guid-of-entity-record-in.html

This was very helpful but in CRM 2013 and also CRM 2015 it does not always work, because in the most circumstances the URL does not include the Guid.

I now tried to modify the script to work also in CRM 2013/2015 and with a little help from the blog here https://crmbusiness.wordpress.com/2014/01/15/crm-2013-quick-way-to-get-the-guid-on-a-form/ I was able to find the best solution for me.

 

  1. Create a new Favorite in your IE
  2. Right-Click and select Properties
  3. On the General Tab you can change the name
  4. On the Web Document tab you can insert following script:
    javascript:(function() {window.prompt('Record ID:',frames[0].Xrm.Page.data.entity.getId())})();
  5. Click OK to save the Favorite

 

The next time you are on a Record you only need to click on the created Favorite Button and you should see the GUID and can also copy it from the MessageBox.

Jan 23
Upgrade throws “Invalid column name ‘MajorVersion’.”

 

When upgrading our test environments we often seeing the following error message:

---------------------------
Error
---------------------------
Action Microsoft.Crm.Setup.Common.Update.DBUpdateAction failed.
Invalid column name 'MajorVersion'.
Invalid column name 'MinorVersion'. Invalid column name 'BuildNumber'. Invalid column name 'DBUpdateActionId'. Invalid column name 'CrmDatabase'.

This only happened to us if you have a MSCRM_CONFIG DB which was generated with CRM 2011 or before.

I found out that in that case you have two possible solutions to this problem:

Solution 1

In this solution I deleted the MSCRM_CONFIG and created a new one with following steps.

1) Uninstall CRM 2013

2) Delete the MSCRM_CONFIG Database

3) Install CRM 2013 with a new blank organization

4) Update the server with the latest RU

5) Import my original organization---> worked without problems

Solution 2

Additionally you have the possibility to do some DB changes to get the upgrade running.

use MSCRM_CONFIG;

Go

EXEC sp_rename 'dbo.DBUpdateInstallInfo','DBUpdateInstallInfo-old'

go

EXEC sp_rename 'dbo.DBUpdateInstallInfo_v5','DBUpdateInstallInfo_v5-old'

Nov 24
CRM Version History

 

Microsoft Dynamics CRM 2013

Name

Date

Build

KB-Article

 

RTM

November 2013

6.0.0.0809

 

UR1

December 2013

6.0.1.0061
6.0.0001.0061

http://support.microsoft.com/default.aspx?kbid=2891271

UR2

March 2014

6.0.2.0046
06.00.0002.0046

 

UR2

April 2014 –Re-release

6.0.2.0051
06.00.0002.0051

http://support.microsoft.com/kb/2919956

UR3

July 2014

6.0.3.0106
06.00.0003.0106

http://support.microsoft.com/kb/2930480

SP1

May 2014

6.1.0.0.0581
6.1.0000.0581

http://support.microsoft.com/kb/2941390

UR1 for SP1

Sep 2014

6.1.1.132

http://support2.microsoft.com/default.aspx?kbid=2953252

Nov 21
Azure VirtualMachine did not start after AzureOutage

Microsoft had this week an AzureOutage for several hours.

For the most of our VM's it was no problem, but we had with two machines the problem that they were not accessible anymore.

In our management portal we saw that one is in mode 'started' and one was in mode 'starting'. Both machines were unreachable.

For both machines we got them up and running with the help of following blog articles:

 

In detail I used following PS commands to get up and running:

 

First you have to logon:
Add-AzureAccount

Now we want to see all VM's
Get-AzureVM

Export the settings in a XML file for the Service
Export-AzureVM -ServiceName 'xxxx' -Name 'xxx' -Path 'c:\temp\vm\ameu005.xml'

Remove the VM but not the Disk
Remove-AzureVM -ServiceName 'xxx' -Name 'xxx'

Create a new VM based on the exported settings
Import-AzureVM -Path 'c:\temp\vm\ameu005.xml' | New-AzureVM -ServiceName 'xxx' -Location 'North Europe'

If you get an error like "disk in use…" when executing the last command, you only wait a little bit and try it again.

Nov 20
I want to use SharePoint Online for my blog

Here in my first blog article I want write about the hurdles to get my first SharePoint Online website up and running.

I have to say that went really smooth. Setting up the page and rename the external URL can be easily done in the SharePoint Admin Center.

The most challenging thing was the favicon. Of course I wanted to change the default SharePoint Icon with my own. This was not as simple as all the other stuff.
The following steps will explain it:

  1. Open the Page Ribbon and cick the View All Pages
  2. In the navigation bar select the Site Contents
  3. I then uploaded the favicon I wanted into the Site Assets Library
  4. In the next step we have to generate a new Master Page. Therefore click on Settings
  5. In the Web Designer Galleries select Master pages and page layouts
  6. Now download the actual Master Page. In my case it was the oslo.master
  7. Search in the file for "…..favicon.ico" and replace it with the location of the custom ico. In my case "/SiteAssets/favicon.ico"
  8. I then renamed it to oslo2.master and uploaded it again to the Master Page Gallery
  9. Now go back to the Settings and select the Master Page Menu from the Look and Feel
  10. There you should be able to select your new master page in the Default
  11. I then made the same for my oslo-mobile.master page